Falha ao obter endereço IP quando conecto no WIFI!

Forum geral sobre discurssão do blackberry curve 8520
Ola,
estou ja algum tempo com esse problema... quando tento conectar na rede wifi aqui de casa ele faz todo o processo normalmente, porém apos aparecer a tela "Conectando a (rede)..." que é quando deveria aparecer a tela "conexão bem sucedida", ele aparece: "Falha ao obter endereço IP". Ja tentei muitas maneiras de configurar, ja desativei a transmissão de dados com a operadora(ate pq nao tenho plano de dados e sairia muito caro) e mesmo assim nao funcionou... e o pior é que é apenas o meu... ja tentei com mais dois BB(nextel) e eles conectaram normalmente. o meu é o BB curve 8520. Obrigado!
dentro de Wi-Fi options, tem a opcao Wi-Fi Tools, e depois Wi-Fi diagnostics.

já tentou executar o diagnostico e ver se tem algum erro?
também de um olhada nos logs do roteador, pode ser que tenha alguma mensagem de erro que identifique o problema.
Fiz o q me disse sobre o Wi-Fi diagnostics. e apareceu:
Endereço IP local: (em branco)
Status: O endereço IP perdeu a validade.
o q eu faço?????? =/
e onde encontro esse tal de "logs do roteador"???
vc tem que conectar no console de gerenciamento do roteador wireless que vc tem na sua casa.

lá deve ter alguma opção para verificar os logs do roteador, pode ser que nesses logs tenha alguma mensagem de erro que permita identificar o que está acontecendo.

o console de gerenciamento é onde vc entra para configurar o roteador.
Eu possuo um blackberry 8520 e estou com o mesmo problema. O detalhe é que minha situação é a mesma do colega acima, porém eu não consigo acessar rede wifi alguma. Acredito que este não seja um problema do roteador. Alguém pode ajudar?
No meu caso tive o mesmo problema, encontrei a solução em um site de3 suporte blackberry USA.
Lá era bem simples:

Entrar em opções
Achar o item rede e entrar;
Definir a opção do serviço de dados como ligado.
Salvar e sair.

Funcionou.... :D

O padrão da blackberry é deixar esse item desligado, dizia o site.

Bom,vale a pena tentar.
andreperry escreveu:No meu caso tive o mesmo problema, encontrei a solução em um site de3 suporte blackberry USA.
Lá era bem simples:

Entrar em opções
Achar o item rede e entrar;
Definir a opção do serviço de dados como ligado.
Salvar e sair.

Funcionou.... :D

O padrão da blackberry é deixar esse item desligado, dizia o site.

Bom,vale a pena tentar.
tava quase jogando meu celular pela janela... hahah
eu so uso wi-fi, não tenho plano de dados porque todos os lugares pra onde vou tem wi-fi... até anteontem funcionava normalmente (casa de amigos, minha casa, faculdade) e de repente começou esse problema de obter endereço IP.

tentei isso que voce falou, e deu certo.
^.^
Também tentei e deu certo, fiquei até com raiva kkk más É só ativar os dados nas configurações /rede movel.
Já que a abordagem é sobre endereço de IP gostaria de indicar o site http://www.localizaip.com.br/ para consulta de Ips que fornece geolocalização.
Problema de encravar a obter endereço de IP numa rede aberta (sem código):
Solução 1:
Nas configurações de LAN do router wifi, escolher o "Tempo de Locação" do servidor DHCP "Para sempre".
Solução 2:
No telemóvel rooteado apagar a pasta completa de nome "misc" dentro da pasta /data
Solução 3:
No telemóvel rooteado apagar o conteúdo da pasta de nome "dalvik-cache" dentro da pasta /data
Solução 4:
No telemóvel, entrar em opções
Achar o item rede e entrar;
Definir a opção do serviço de dados como ligado.
Salvar e sair.
Solução 5:
Nas configurações do router wifi, mudar a banda de b, g e n para g e n.
Solução 6:
Repor o router wifi às definições de fábrica
Solução 7:
Repor o telemóvel às definições de fábrica.

Após estes passos todos, ficou a dar, mas não logo a seguir a eles. Apenas no dia seguinte...